Technical Incident: Connection Timed Out Deferrals
Incident Report for SendGrid
Resolved
Due to high volumes some customers may have experienced larger than normal deferral rates but the surge in sending has subsided. Email is flowing well and all systems appear normal. Please contact our support team if you have any questions: https://support.sendgrid.com
Posted Nov 25, 2016 - 08:59 PST
Update
Our Ops team is digging into the source of the Connection Timed Out deferrals within our system and are working to determine a speedy resolution.
Posted Nov 25, 2016 - 05:55 PST
Investigating
We are currently investigating reports of emails being deferred. Our Operations team is investigating the root cause with the highest priority. Stay tuned - we'll post updates here as we have them.
Posted Nov 25, 2016 - 05:43 PST