Technical Incident: Email Delays
Incident Report for SendGrid
Resolved
We're calling this technical incident resolved. Delayed mail has been dequeueing since the last update. Mail traffic is sending at normal speeds.

We deeply apologize for any inconvenience you may have encountered with delayed messages. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted Aug 26, 2016 - 13:16 PDT
Identified
Our Operations team is managing traffic to help dequeue and mitigate delays. Mail that was delayed is now being sent. We’re watching queues closely and will continue to provide updates.
Posted Aug 26, 2016 - 09:19 PDT
Investigating
We are aware and currently investigating reports of email delays caused by network issues that may be affecting some customers. We have our Operations team looking at this with the highest priority, and we will update shortly with more information on a resolution.
Posted Aug 26, 2016 - 07:36 PDT