Service Disruption: Click and open tracking not resolving
Incident Report for SendGrid
Resolved
We're declaring this service disruption resolved. We apologize for any inconveniences you may have experienced. Click and open tracking services are stable, and click track links are quick to redirect. Click and open tracking stats will not display in your account or webhook approximately between 6:50AM and 10:42AM MDT. Please let our support team know if you have any questions: https://support.sendgrid.com -RC
Posted May 01, 2016 - 10:22 PDT
Monitoring
Update: Our engineering team identified the issue. Click and Open tracking services are slowly being restored. Click tracking links may be slow to resolve. We're continuing to monitor performance. -RC
Posted May 01, 2016 - 09:15 PDT
Update
Update: Our engineering team is still working hard to investigate the root cause of click and open tracking not resolving.

You may see a slight increase in latency connecting with SendGrid - RC
Posted May 01, 2016 - 08:30 PDT
Update
Update: Our engineering team is investigating the root cause of this service disruption. Customers will see links being unreachable if click tracking is enabled. Open tracking is also affected, and is not being tracked. - RC
Posted May 01, 2016 - 07:24 PDT
Investigating
Our engineering team is currently investigating reports of Click Tracking links not resolving. We will update with more information shortly.
Posted May 01, 2016 - 06:46 PDT