Email Activity page not updating properly
Incident Report for SendGrid
Resolved
The issues that were causing our Email Activity page to misbehave have been resolved and everything should be back to normal now. No email activity data was lost. Thanks again for your patience while we worked to get this resolved!
Posted Jun 18, 2015 - 22:36 PDT
Investigating
We are currently investigating reports from a part of our customer base about the Email Activity page having stopped displaying events at around 5 PM MST. Mail flow is not impacted, all traffic is being relayed as normal - this is only an UI display issue.
We appreciate your patience and understanding while we look into this!
Posted Jun 18, 2015 - 22:20 PDT