Support Portal System Disruption
Incident Report for SendGrid
Resolved
Our ticketing vendor has resolved their issue and our support team is currently working through the backlog. Thank you for your patience. Please contact Support with questions: https://support.sendgrid.com/.
Posted 9 months ago. Mar 15, 2017 - 17:06 PDT
Identified
Access to our support help center may be intermittent for some customers due to a service interruption from our support ticketing vendor. As soon as it becomes available, we will work diligently to respond to all recently logged support tickets. In the meantime please use sendgrid.com/docs to browse our knowledge base and view self help resources. Thank you for your patience.
Posted 9 months ago. Mar 15, 2017 - 14:37 PDT