Technical Incident: Paid Sign Up and Upgrade Intermittent Availability
Incident Report for SendGrid
Resolved
We have restored all intermittently available services and are confident paid sign ups and upgrades are fully operational. If you were unable to upgrade or create a free account during this time, you will now be able to upgrade to the paid plan of your choice. We apologize for any inconvenience this may have caused. Please reach out to our Support Team at https://support.sendgrid.com with any questions.
Posted 5 months ago. Jan 27, 2018 - 01:18 PST
Identified
We have resolved the issue causing an error when attempting to upgrade from a free to paid account. If you experienced an error during that time, please try again now.

We are currently working on a fix for errors when signing up for a paid account. In the meantime, if you experience an error during paid sign up, please sign up for a free account. If you have any questions reach out to our Support team at https://support.sendgrid.com.
Posted 5 months ago. Jan 26, 2018 - 20:49 PST
Investigating
We are currently seeing reports of intermittent errors when signing up for a paid account or upgrading to a paid account. If you are attempting to upgrade, please retry as the issue is intermittent. If you are unable to sign up for a paid account, please sign up for a free account in the meantime. We'll continue to follow the investigation and provide updates. Please reach out to our Support Team at https://support.sendgrid.com/ with any questions.
Posted 5 months ago. Jan 26, 2018 - 17:11 PST
This incident affected: Website.