Billing actions within site are down
Incident Report for SendGrid
Resolved
This incident has been resolved.
Posted Jun 30, 2015 - 20:40 PDT
Identified
Our billing provider is currently seeing issues with their API. This affects all billing actions within our UI unfortunately. They are working on resolving this issue and we will be monitoring the status and updating you here. Please contact support@sendgrid.com if you have any questions. We apologize for the inconvenience. - AI
Posted Jun 30, 2015 - 17:44 PDT