Delayed Delivery to Microsoft Domains
Incident Report for SendGrid
Resolved
We have seen a return to our anticipated rate of delivery to Microsoft domains. Thank you for your patience.
Posted about 1 month ago. Sep 18, 2017 - 16:30 PDT
Monitoring
We are currently seeing increased delivery times to Microsoft domains. Please refer to their status page at https://portal.office.com/servicestatus. We will resolve this post when the delivery to these domains returns to the expected rate.
Posted about 1 month ago. Sep 18, 2017 - 10:11 PDT