Mail processing delays
Incident Report for SendGrid
Resolved
Our ops team has resolved the delays and verified that mail is now queueing at the expected rate. No mail was lost during this time. We apologize for any inconvenience this caused you. Please let our support team know if you have any questions, support[@}sendgrid.com. -jz
Posted Jul 20, 2015 - 17:14 PDT
Investigating
Our Ops team is currently investigating mail processing delays for a small subset of customers beginning at approximately 3:30pm MT. Our system is dequeuing now and we expect the delays to resolve shortly. We will update here when there is more information to share. -jz
Posted Jul 20, 2015 - 16:48 PDT