Service Outage - Paid Signup and Credit Card Modification
Incident Report for SendGrid
Resolved
Our Operations team has reverted to our primary billing provider at this time. We appreciate your patience and apologize for any inconvenience this may have caused. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted 17 days ago. Jan 03, 2019 - 14:57 PST
Update
Our Operations team is continuing to monitor the situation until we revert to our primary provider. We will provide another update when this is complete. Please reach out to our Support team with any questions at https://support.sendgrid.com/
Posted 17 days ago. Jan 03, 2019 - 13:24 PST
Monitoring
Beginning at 10:03AM MST, one of our third party billing providers began experiencing an issue which caused paid signups and changes to credit card information to be unavailable on our platform. At 11:34 AM MST, SendGrid moved to our backup provider, which made paid signups and credit card changes available again. If you experienced any issues when attempting to sign up for a new account during this window, please try again at this time. We apologize for any inconvenience this may have caused and are continuing to monitor the situation until we revert to our primary provider. Please reach out to our Support team with any questions at https://support.sendgrid.com/
Posted 17 days ago. Jan 03, 2019 - 11:11 PST
This incident affected: Website.