Service Disruption: Authentication and Mail Availability
Incident Report for SendGrid
Resolved
The root cause of this service disruption has been mitigated. Authentication and mail send availability have been restored. We apologize for any inconvenience this may have caused, please reach out to our Support Team at https://support.sendgrid.com with any questions.
Posted 24 days ago. Jul 26, 2017 - 01:16 PDT
Investigating
We're currently investigating reports of authentication errors and login issues. Customers may also experience a delay in mail flow and stats reporting. We're actively working to determine the root cause and will provide additional updates shortly.
Posted 24 days ago. Jul 26, 2017 - 00:04 PDT