New customers may have trouble signing up
Incident Report for SendGrid
Resolved
New account signups are now functioning correctly and parent accounts can now Create New Subusers. We apologize for the inconvenience. Please let our support team know if you have any questions
Posted Apr 25, 2016 - 03:44 PDT
Update
Update: Our Operations team continues to investigate the sign up issue. Some customers may also experience issues while creating new subusers. We'll be back with more detailed updates as they become available
Posted Apr 25, 2016 - 03:15 PDT
Investigating
We are currently investigating this issue. More updates to follow. We apologize for the inconvenience -ab
Posted Apr 25, 2016 - 02:56 PDT