Technical Incident: Sign Up and Login Page Availability
Incident Report for SendGrid
Resolved
Thank you for your patience. We have been monitoring the site and are no longer seeing intermittent login issues. Please reach out to our Support Team at https://support.sendgrid.com/ if you have any questions.
Posted 3 months ago. Sep 29, 2017 - 13:18 PDT
Investigating
We are currently investigating reports of intermittent availability of our login and sign up pages. We apologize for any inconvenience. If you have any questions please reach out to our Support team by emailing us directly at support@sendgrid.com.
Posted 3 months ago. Sep 29, 2017 - 11:05 PDT
This incident affected: Website.