Technical Incident: Email Delays
Incident Report for SendGrid
Resolved
The portion of mail that was queued and delayed has finished processing. Our operations team has been closely monitoring performance, and has confirmed this issue to be resolved. We sincerely apologize for any inconvenience you may have experienced. Please contact our support team if you have any questions: https://support.sendgrid.com.
Posted Sep 13, 2016 - 14:52 PDT
Monitoring
We've confirmed the root cause to be a single mail processing server becoming unresponsive resulting in some mail being queued and delayed. All mail from this server is now being delivered via other servers. Only a portion of email was handled by this server. We'll continue to closely monitor progress.
Posted Sep 13, 2016 - 12:07 PDT
Identified
We are aware and currently investigating reports of email delays that may be affecting a small subset of customers. Our Operations team has identified the root cause and is looking at this with the highest priority. We will update shortly with more information on a resolution.
Posted Sep 13, 2016 - 10:20 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).