Technical Incident: Marketing Campaigns Contacts Availability
Incident Report for SendGrid
Resolved
Marketing Campaigns sending has been fully restored to all users at the expected performance level you can trust from our service.

Our team is working with a handful of users who need additional, account-specific resolution related to their contact databases. We are communicating individually with these customers and will continue to update them directly moving forward. We sincerely thank you for your patience. We will add a post-resolution update with a detailed Post Mortem when we have one to share. Please reach out to our Support team with any questions at https://support.sendgrid.com.
Posted about 1 month ago. Nov 12, 2017 - 14:00 PST
Update
Marketing Campaigns sending has been fully restored to all users. Our team will continue to work on recipient data discrepancies for a small number of remaining users. We'll provide updates as we have more information. We sincerely thank you for your patience. Please reach out to our Support team with any questions at https://support.sendgrid.com.
Posted about 1 month ago. Nov 11, 2017 - 21:28 PST
Update
We are continuing our efforts to restore recipient data and sending for a very small portion of Marketing Campaigns users. All other users are fully restored and functional. We'll provide another update as we have information. In the mean time, don't hesitate to contact our Support team with any questions at https://support.sendgrid.com. Thank you for your patience.
Posted about 1 month ago. Nov 11, 2017 - 05:20 PST
Update
We have restored sending for the majority of our Marketing Campaigns users. A subset of customers will see their campaigns as "Scheduled" while we work to restore their recipient data. Our team is all hands on deck to complete the restoration of recipient data for the impacted users, we will post an update as soon as we have additional information. Please reach out to our Support team with any questions at https://support.sendgrid.com.
Posted about 1 month ago. Nov 10, 2017 - 23:12 PST
Update
Our team is continuing to work toward restoring recipient data. Marketing Campaign sends have temporarily been suspended to avoid sending to incomplete recipient lists. We will provide an update as soon as we have additional information. We sincerely apologize for the inconvenience and thank you for your continued patience. Please reach out to our Support team with any questions at https://support.sendgrid.com.
Posted about 1 month ago. Nov 10, 2017 - 19:17 PST
Update
Thank you for your continued patience. Our team is working diligently towards a solution to restore recipient data, after which we will resume sending for Marketing Campaigns. We truly apologize for the inconvenience. Please reach out to the Support team with any questions at https://support.sendgrid.com/
Posted about 1 month ago. Nov 10, 2017 - 18:16 PST
Update
While making changes to increase stability in our system, a subset of recipient data was relocated within one of our data centers. During the relocation, this subset of recipient data did not fully propagate for some accounts. We are in the process of restoring the data and will continue to provide updates. Once recipient data is restored, we will resume sending for Marketing Campaigns, which has temporarily been paused to avoid mail being sent to incomplete recipient lists. Thank you for your patience and please contact our Support team with any questions: https://support.sendgrid.com/
Posted about 1 month ago. Nov 10, 2017 - 17:34 PST
Update
Our team is continuing to work on restoring users' contacts to full availability, so that we can resume sending for Marketing Campaigns. We have all-hands on deck and are working to resolve the issue. We apologize for the mail delay and thank you for your patience. Please contact our Support team with any questions: https://support.sendgrid.com/
Posted about 1 month ago. Nov 10, 2017 - 17:08 PST
Identified
We have identified the issue causing inconsistencies in users’ contact storage. Our team is working to restore users' contact storage to full availability so we can resume sendings for Marketing Campaigns. We apologize for the mail delay and thank you for your patience. Please contact our Support team with any questions: https://support.sendgrid.com/
Posted about 1 month ago. Nov 10, 2017 - 16:29 PST
Investigating
A small subset of customers are reporting an inconsistency in contact availability within our Marketing Campaigns app. Our team is currently investigating. We are going to queue Marketing Campaigns sends momentarily and will provide additional information shortly. Thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/
Posted about 1 month ago. Nov 10, 2017 - 15:54 PST
This incident affected: Marketing Campaigns (Marketing Campaigns).