Mail Delays
Incident Report for SendGrid
Resolved
We have monitored our system performance and confirmed that the issues have been resolved. We apologize for any inconvenience this caused. Please reach out to our Support team with any additional questions: https://support.sendgrid.com.
Posted about 2 months ago. Oct 27, 2017 - 14:04 PDT
Monitoring
During our investigation of mail delays, there was a brief moment where users may have been unable to log in to their accounts. Our Ops team has identified and resolved both issues. Any mail that was delayed has successfully dequeued. We will continue to monitor to ensure the efficacy of the solution. Thank you for your patience. Please reach out to our Support Team with any questions: https://support.sendgrid.com/
Posted about 2 months ago. Oct 27, 2017 - 12:40 PDT
Investigating
A small subset of customers are experiencing a higher than normal processing time for their messages. Our Ops team is currently investigating. We will provide additional information shortly. Thank you for your patience. Please contact our Support team with any questions at https://support.sendgrid.com/
Posted about 2 months ago. Oct 27, 2017 - 09:47 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).