Temporary deferrals for Microsoft domains
Incident Report for SendGrid
Resolved
Microsoft has reported that this issue is resolved. Mail should flow normally now to Microsoft domains. For more information please see https://portal.office.com/servicestatus. - LJ
Posted May 25, 2016 - 19:03 PDT
Investigating
Microsoft domains currently appear to be deferring all mail sent to them. This is not a SendGrid issue but as per normal deferral rules we will continue to retry requests headed for Microsoft managed domains for up to 72 hours. - RL
Posted May 25, 2016 - 12:23 PDT