Service Disruption - Paid sign up unavailable
Incident Report for SendGrid
Resolved
New account signups are functional again. We apologize for the inconvenience this caused. Please let our support team know if you have any questions: https://support.sendgrid.com/hc/en-us. -jz
Posted May 27, 2016 - 11:59 PDT
Identified
Our engineers have identified the issue and are working to deploy a fix. We'll provide updates as we have them. Thank you for your patience. -jz
Posted May 27, 2016 - 10:38 PDT
Investigating
We're currently investigating an issue preventing sign up for new accounts. More updates to follow. We apologize for any inconvenience. Please let our support team know if you have any questions: https://support.sendgrid.com/hc/en-us. -jz
Posted May 27, 2016 - 09:45 PDT