SSL Certificate Issues
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with SSL Links has been resolved. All services are now operating normally at this time.
Posted Jul 03, 2024 - 16:03 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. Users previously experiencing SSL link issues should no longer be experiencing issues with SSL links. We will provide another update in one hour or as soon as more information becomes available.
Posted Jul 03, 2024 - 15:24 PDT
Update
Our team is continuing to work towards a fix. You can expect an update in four hours or sooner if new information is available.
Posted Jul 03, 2024 - 13:17 PDT
Update
As of July 3 - 11:30am PDT our engineering team has identified the issue and is continuing to work towards a fix. You can expect an update in two hours or sooner if new information is available.
Posted Jul 03, 2024 - 11:38 PDT
Update
As of July 3 - 9:30am PDT our engineering team has identified the issue and is working towards a fix. You can expect an update in two hours or sooner if new information is available.
Posted Jul 03, 2024 - 09:36 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 03, 2024 - 08:14 PDT
Monitoring
Our engineering team has implemented a fix and is continuing to monitor the issue
Posted Jul 03, 2024 - 07:34 PDT
Update
Our Engineers are working towards a fix. We will provide another update as soon as more information becomes available.
Posted Jul 03, 2024 - 04:52 PDT
Identified
Our engineers have identified the issue and are working towards a fix. We will provide another update as soon as more information becomes available.
Posted Jul 03, 2024 - 01:30 PDT
Investigating
As of today July 2nd, 2024 we continue to investigate the incident of click tracking certificate issues for a subset of customers who enabled SSL click tracking and sent mailsend requests between 9:30 AM PT and 3:50 PM PT on June 27th, 2024. This does not impact mail sending.
Our engineering team is actively investigating the root cause of the SSL certificate issues affecting click tracking. We will provide another update as soon as more information becomes available.
Posted Jul 02, 2024 - 18:56 PDT
This incident affected: Statistics.