Technical incident - Blocks caused by 501 Syntax error - Badly formatted address errors
Incident Report for SendGrid
Resolved
We have identified and resolved the issue causing smaller mailbox receivers to reject and block mail with a 501 or 555 response. These resulted in SendGrid ‘block’ events, and are not suppressed on future sends.

We sincerely apologize for any inconvenience. If you have questions or need additional information, please contact SendGrid Support directly:http://support.sendgrid.com - RC
Posted Aug 25, 2016 - 10:37 PDT
Update
The incident is still under investigation.Thank you for your patience and cooperation and we are sorry for any inconvenience that this might cause. ^AC
Posted Aug 25, 2016 - 04:44 PDT
Investigating
We are currently investigating an issue according to which some users might have their emails blocked with the following error: "501 Syntax error - Badly formatted address". Updates to follow. ^AC
Posted Aug 25, 2016 - 03:15 PDT