Service Disruption - Delays in Segment-Based Marketing Campaigns Automation Emails
Incident Report for SendGrid
Resolved
This incident has been declared resolved. Marketing Campaigns Automations should now function as expected. We apologize for any inconvenience and thank you for your patience.
Posted Feb 05, 2021 - 13:46 PST
Monitoring
Our engineers have implemented a fix and are now monitoring its performance. Customers may still observe delays in segment-based automation emails and delays to contact segment updates. We will provide an update within the next 60 minutes or less as updates become available.
Posted Feb 05, 2021 - 12:46 PST
Investigating
Around 12PM MT, our Engineering teams became aware of an issue where a small number of customers have the potential to see duplicate emails sent to their contacts via the Automations feature when attached to a contact segment.

Our Engineers are working on a fix to mitigate this issue and in the meantime, customers may see delays in segment-based automation emails and may also experience delays when updating segments. We will provide an update within the next 60 minutes or less as updates become available.
Posted Feb 05, 2021 - 12:17 PST
This incident affected: Marketing Campaigns (Marketing Campaigns).