API Connection Errors, Mail Send Delays, and Site Unavailability
Incident Report for SendGrid
Resolved
We have monitored the fix and confirmed the issue has been resolved. Our systems are operating normally at this time.
Posted Feb 24, 2021 - 17:32 PST
Monitoring
A fix has been implemented and we are no longer seeing delays to Marketing Campaigns and Marketing Campaigns related Stats. We will continue to monitor for system stability and provide another update in 16 hours or as soon as more information becomes available.
Posted Feb 24, 2021 - 17:02 PST
Update
Our engineers are continuing to work toward a fix. Customers may still notice delays for Marketing Campaigns and Marketing Campaigns related Stats. There may be some intermittent connection issues for Marketing Campaigns API. Stats and webhook posts are caught up now. We will provide updates in the next 8 hours or sooner as they become available.
Posted Feb 24, 2021 - 16:00 PST
Identified
Our engineers have identified the issue and are working toward a fix. Customers may still notice delays for Marketing Campaigns and Stats. There may be some intermittent connection issues for Marketing Campaigns API. Stats and webhook posts are still delayed. We will provide updates in the next 4 hours or sooner as they become available.
Posted Feb 24, 2021 - 14:49 PST
Update
Our engineers are still investigating this issue. The site at app.sendgrid.com should be available again. Mail queues are mostly caught up but may have some delays. Customers may still be experiencing intermittent API connection issues, and also notice delayed stats and webhook posts. We will provide updates in the next 2 hours or sooner as they become available.
Posted Feb 24, 2021 - 13:44 PST
Update
Our engineers are still investigating this issue. The current customer impact includes API connection errors, mail send delays, and site unavailability. Customers may receive 5xx errors when making API calls, but mail send requests should now be working again. Customers may also notice mail send delays, including Marketing Campaigns. Also, customers may have difficulty accessing our site at app.sendgrid.com. We will provide updates in the next hour or sooner as they become available.
Posted Feb 24, 2021 - 12:48 PST
Investigating
Starting around 12:39PM MT, we are experiencing issues with API connections, mail send delays, and site unavailability. Customers may receive 5xx errors when making API calls, including mail send. Customers may also notice mail send delays, including Marketing Campaigns. Also, customers may have difficulty accessing our site at app.sendgrid.com. Our engineers are investigating the issue. We will provide updates in the next 30 minutes or sooner as they become available.
Posted Feb 24, 2021 - 12:17 PST
This incident affected: Marketing Campaigns (Marketing Campaigns), Mail Sending (API v3, SMTP, API v2), Webhooks (Event Webhook), and API, Website.