“Our engineers have monitored the fix and confirmed the issue with Inaccurate Global stats has been resolved. All services are now operating normally at this time.”
Posted Jun 12, 2023 - 22:04 PDT
Monitoring
Our engineers have implemented a fix and are monitoring the system's performance. We will provide another update as soon as more information becomes available.
Posted Jun 12, 2023 - 21:41 PDT
Identified
Our engineers are continuing to investigate this issue with Global Statistics. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 12, 2023 - 20:51 PDT
Update
Our engineers have implemented a fix and are monitoring the system's performance. We will provide another update as soon as more information becomes available.
Posted Jun 12, 2023 - 18:48 PDT
Monitoring
Our engineers have implemented a fix and are monitoring the system's performance. We will provide another update in an hour or as soon as more information becomes available.
Posted Jun 12, 2023 - 17:42 PDT
Update
Our engineers are continuing to investigate this issue with Global Statistics. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 12, 2023 - 17:00 PDT
Update
Our engineers are continuing to investigate this issue with Global Statistics. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 12, 2023 - 16:04 PDT
Investigating
Starting around 2:30 PM PT on June 12th, our engineers began investigating an issue with Global Statistics. Users may experience inaccurate, deflated statistics dating back to June 4th, 2023 beginning at approximately 4:00 PM PT. This does not impact mail send. We will provide another update in one hour or as soon as more information becomes available.