Scheduled Mail Cancelled via Batch IDs May Still Send Some Mail
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with cancelling scheduled mail sends has been resolved. All services are now operating normally at this time.
Posted Jun 14, 2022 - 17:53 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Jun 14, 2022 - 17:20 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in an hour or as soon as more information becomes available.
Posted Jun 14, 2022 - 17:01 PDT
Update
Our engineers are still investigating an issue with cancelling scheduled mail sends. We will provide another update within the next hour or as more information becomes available.
Posted Jun 14, 2022 - 16:45 PDT
Update
Our engineers are still investigating an issue with scheduled mail sends. At this time, mail scheduled via API using a batch ID may not be properly cancelled when hitting the cancellation endpoint. Some mail within the batch may still be sent. This only impacts mail sent via API that is scheduled and then cancelled. We will provide another update within the next hour or as more information becomes available.
Posted Jun 14, 2022 - 15:45 PDT
Investigating
Starting at 2:28 PM PT, our engineers began investigating an issue with scheduled mail sends. At this time, mail scheduled via API using a batch ID may not be properly cancelled when hitting the cancellation endpoint. Some mail within the batch may still be sent. This only impacts mail sent via API that is scheduled and then cancelled. We will provide another update within the next hour or as more information becomes available.
Posted Jun 14, 2022 - 14:45 PDT
This incident affected: Mail Sending (API v3).