Global Stats Delay
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with delayed Global Stats has been resolved. All services are now operating normally at this time, and all Global Stats have been restored.
Posted May 24, 2023 - 09:40 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour, or as soon as more information becomes available.
Posted May 24, 2023 - 09:05 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 24, 2023 - 09:03 PDT
Identified
Our engineering team has identified the issue and are working towards a fix. Only stats for events occurring after 4:30 PM PT on May 23rd are impacted. We will provide another update within an hour or as soon as more information becomes available.
Posted May 24, 2023 - 08:36 PDT
Investigating
Starting around 7:00 A.M. PT on May 24, our engineers started investigating delays with Global Stats. Customers may experience delays for the posting of stats. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 24, 2023 - 07:38 PDT
This incident affected: Statistics.