Service Disruption: Paid Account Signups and Upgrades
Incident Report for SendGrid
Resolved
We have verified the third party billing maintenance is complete and our services are available. We thank you for your patience and apologize for any inconvenience this may have caused. Please reach out to our Support team if you have any questions at https://support.sendgrid.com/.
Posted 4 months ago. Apr 20, 2019 - 21:56 PDT
Monitoring
From about 8:45PM MT to 10:15PM MT, one of our third party billing providers performed a maintenance which caused paid signups and account upgrades to be unavailable on our platform. If you had experienced any difficulties attempting to upgrade your account or sign up for a paid account during this time, please try again. We are continuing to monitor this, and greatly apologize for any inconvenience this may have caused. Please reach out to our Support team if you have any questions at https://support.sendgrid.com/.
Posted 4 months ago. Apr 20, 2019 - 21:31 PDT
This incident affected: Website.