Delays with Mail Sending
Incident Report for SendGrid
Resolved
Our engineers have implemented a fix and confirmed that the delays seen with mail sending have been resolved. All services are now operating normally at this time.
Posted Aug 04, 2021 - 09:48 PDT
Monitoring
Our Engineers have implemented a fix and are monitoring system performance. Impacted customers will begin to see delayed mail flow and new mail will not be impacted. We will provide another update in the next hour or as any new information becomes available.
Posted Aug 04, 2021 - 09:17 PDT
Update
As we continue to investigate and identify this issue, a subset of customers may have been seeing delays on new mails sent around 8:22 am PT. We will continue to update within another hour or as soon as additional information becomes available.
Posted Aug 04, 2021 - 09:04 PDT
Investigating
Beginning around 7:05 am PT on Wednesday, August 04th, our engineers discovered delays with mail being sent for a subset of customers. Customers affected by this will not see delays on new sends but may see delays with mail previously sent out around 7:05 am PT via API v3, API v2, SMTP and Marketing Campaigns. We will provide updates as more information becomes available.
Posted Aug 04, 2021 - 08:19 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).