Customers unable to make Upgrade/Downgrade Requests
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with plan upgrades and downgrades has been resolved. All services are now operating normally at this time.
Posted Jul 25, 2024 - 13:39 PDT
Monitoring
Our engineers have implemented a fix at 12:37 PST and are monitoring system performance. Currently, upgrades and downgrades can be made. We will provide another update in an hour or as soon as more information becomes available.
Posted Jul 25, 2024 - 13:04 PDT
Identified
Our engineers identified the issue at 12:04 PST and are working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 25, 2024 - 12:57 PDT
Investigating
Starting around 11:52 PST on July 25th, our engineers began investigating an issue that prevent customers from upgrading or downgrading their SendGrid plans. Users may see a "We're sorry, something went wrong" error. This does not impact mail send. We will provide another update in one hour or as soon as more information becomes available.
Posted Jul 25, 2024 - 12:50 PDT
This incident affected: Website.