SendGrid Mail Sending Delays
Incident Report for SendGrid
Resolved
After monitoring, our engineers confirmed that changes deployed to correct the identified hardware problem solved the issue and new mail traffic requested to the SendGrid system will not be delayed. This incident has been resolved.
Posted Feb 06, 2024 - 18:08 PST
Update
The system is continuing to be monitored at this time as it relates to this incident. Another update will be provided in one hour or as soon as more information becomes available.
Posted Feb 06, 2024 - 17:34 PST
Monitoring
Our engineers confirmed that delayed emails due to this hardware problem have been successfully dequeued from the system. New mail traffic requested to the SendGrid system will not be delayed due to this problem as changes were deployed to correct the identified hardware problem. The system will continue to be monitored and another update will be provided in the next hour or as soon as possible.
Posted Feb 06, 2024 - 16:33 PST
Identified
Starting at 3:00 PM PT on February 6, 2024, our engineers confirmed an issue with the hardware related to mail send for the SendGrid platform. Due to this hardware issue, users of the platform may have experienced delays in mail send requests to the system. Our engineering team deployed a change to help mitigate affected delayed traffic at 3:42 PM PT. While this does affect mail send, only a subset of customers sending mail were affected. We will provide another update in one hour or as soon as more information becomes available.
Posted Feb 06, 2024 - 16:08 PST
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).