SendGrid API Doc web pages failing to load
Incident Report for SendGrid
Resolved
This incident has been resolved. Customers may have experienced 500 or 404 errors when trying to access API documentation from about 9am PT until about 1:30 PM PT on June 16. The vast majority of documentation should now be able to be accessed. Please reach out to SendGrid support if you continue to encounter 500 or 404 errors when trying to access API documentation.
Posted Jun 16, 2021 - 14:49 PDT
Monitoring
We are monitoring the issue of 500 and 404 errors on our API docs. A fix has been deployed, and we are seeing that docs that were previously inaccessible are now able to be accessed, although the process is still rolling out and some docs may continue to show errors in the short term. We will continue to monitor and provide more information as it becomes available.
Posted Jun 16, 2021 - 13:52 PDT
Identified
We are continuing to monitor the 500 type error issue with our API docs. We have also identified that there are a subset of docs that are now returning 404 errors when accessed and are reviewing these errors as well. Please continue to access the API reference documentation at https://sendgrid.api-docs.io/v3.0/ in the meantime. Another update will be provided when more information has become available.
Posted Jun 16, 2021 - 12:14 PDT
Update
Access to most API Docs have been restored at this time. We are continuing to monitor this issue and are continuing to deploy a fix to bring the remaining documents back online. Please continue to access the API reference documentation at https://sendgrid.api-docs.io/v3.0/ in the meantime. Another update will be provided when more information has become available.
Posted Jun 16, 2021 - 11:13 PDT
Update
We are continuing to monitor this issue at this time. Please continue to access the API reference documentation at https://sendgrid.api-docs.io/v3.0/ in the meantime. We will provide another update in about an hour or as more information becomes available.
Posted Jun 16, 2021 - 10:05 PDT
Monitoring
We are currently monitoring an issue with some SendGrid API reference documentation web pages. Some API reference pages may be failing to load and returning `500` errors. The issue was discovered at about 8AM PT on June 16. Customers can continue to access the API reference information at https://sendgrid.api-docs.io/v3.0/ while we work to resolve the issue. A fix is being deployed. This issue impacts documentation only; all APIs are working as expected. We will provide another update in about an hour or as more information becomes available.
Posted Jun 16, 2021 - 09:03 PDT
This incident affected: Website.