Sendgrid API
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Mail Send, Non Mail Send, Sendgrid Console (User Interface), Marketing Campaigns has been resolved. All services are now operating normally at this time.
Posted Dec 24, 2022 - 18:48 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 24, 2022 - 18:13 PST
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in an hour or as soon as more information becomes available.
Posted Dec 24, 2022 - 18:08 PST
Identified
The issue was identified and our Engineers have implemented a fix. Mail Send, Non Mail Send, Sendgrid Console (User Interface), Marketing Campaigns had intermittent error responses. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Dec 24, 2022 - 17:23 PST
Investigating
Starting around 6:00 on Saturday 24th, 2022, our engineers began investigating an issue with Sendgrid API. Customers may experience API timeout and errors with API.
Posted Dec 24, 2022 - 16:25 PST
This incident affected: Mail Sending (API v3, SMTP, API v2) and Marketing Campaigns (Marketing Campaigns).