New Marketing Campaigns Contact Writes Are Delayed

Incident Report for SendGrid

Update

The third-party vendor is currently implementing a fix. We are closely monitoring progress and will provide an update within two hour or sooner as more information becomes available
Posted Dec 16, 2025 - 03:56 PST

Update

The third party vendor is still implementing a fix. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 16, 2025 - 01:45 PST

Update

The third party vendor is still implementing a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 15, 2025 - 23:46 PST

Update

We are continuing to work on a fix for this issue.
Posted Dec 15, 2025 - 22:30 PST

Update

The third party vendor is still implementing a fix. All customers will continue to experience delay in New Marketing Campaigns Contact writes. Mail send is not affected. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 15, 2025 - 22:24 PST

Identified

Starting around 19:48 PT on 12/15/2025, all customer using New Marketing Campaigns contact writes may experience delays due to an ongoing issue with our third party vendor. The third party vendor has identified the issue and is working on a fix. Mail send is not affected. We will provide another update in 60 minutes.
Posted Dec 15, 2025 - 21:19 PST
This incident affects: Marketing Campaigns (Marketing Campaigns).