Increased Errors to Mail Send Endpoints and Increased SMTP Timeouts
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Mail Send has been resolved. All systems are operating as expected at this time.
Posted Sep 21, 2023 - 15:20 PDT
Monitoring
Our Engineers have implemented a fix and we are currently monitoring to ensure no more delay occurrences are detected.
Posted Sep 21, 2023 - 14:39 PDT
Identified
The issue was identified and our Engineers are working on a fix right now. We are actively working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 21, 2023 - 14:22 PDT
Investigating
Starting around 12:00 PM PT on Thursday September 21st, 2023, our engineers began investigating an issue with Sendgrid API, affecting Mail Send requests to the v3 API, v2 API, and our SMTP servers. Customers may have experienced an increase in 5xx errors when attempting to send mail. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 21, 2023 - 14:10 PDT
This incident affected: Mail Sending (API v3).