Customers unable to make Plan Changes from Pro plans or to Pro plans
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with making plan changes has been resolved. All services are now operating normally at this time.
Posted Apr 02, 2024 - 00:14 PDT
Update
Our engineers have monitored the fix and confirmed the issue with making plan changes has been resolved. All services are now operating normally at this time.
Posted Apr 01, 2024 - 13:30 PDT
Monitoring
Our engineers have deployed a fix and are monitoring system performance. We will provide another update in an hour or as soon as more information becomes available.
Posted Apr 01, 2024 - 12:47 PDT
Update
Our engineering team is continuing to work on a fix for this issue. We appreciate your patience as we work to resolve this. We will provide another update in hour or as soon as more information becomes available.
Posted Apr 01, 2024 - 11:04 PDT
Update
Our engineers have identified the issue and are continuing to work toward a fix. We will provide another update in hour or as soon as more information becomes available.
Posted Apr 01, 2024 - 09:13 PDT
Identified
Starting around 12:05 AM PST on April 1st, our engineers began investigating an issue for users unable to make changes on their plans. Any customers who want to upgrade to Pro, or with a Pro email API plan will not be able to make changes. When upgrading the plan, users may encounter an issue saying "We're sorry, something went wrong. Please contact support." A fix should be applied soon. Mail Send is not impacted. We will provide another update in an hour, or as soon as more information becomes available.
Posted Apr 01, 2024 - 08:10 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Billing.