Possible Webhook POST Delays and Marketing Campaigns Issues
Incident Report for SendGrid
Resolved
We have monitored the fix and everything is in working order. We apologize for the inconvenience this issue has been.
Posted Nov 26, 2020 - 12:28 PST
Monitoring
The fix is currently being monitored to ensure no further issues come up. We apologize for the inconvenience. We will post an update as soon as one is available.
Posted Nov 26, 2020 - 06:17 PST
Update
We are currently monitoring the fix that has been implemented. Single Sends and Automations have been turned back on and adding or updating contacts should no longer be delayed. We apologize for the inconvenience. We will post an update as soon as one is available.
Posted Nov 26, 2020 - 00:34 PST
Update
We are currently monitoring the fix our third party has implemented. We apologize for the inconvenience. We will post an update as soon as one is available.
Posted Nov 25, 2020 - 23:16 PST
Update
We are continuing to monitor as our third party works towards implementing a fix. We apologize for the inconvenience. Please expect an update within two hours.
Posted Nov 25, 2020 - 21:14 PST
Update
We will continue to monitor as our third party works towards implementing a fix. We apologize for the inconvenience. Please expect another update within two hours.
Posted Nov 25, 2020 - 19:12 PST
Update
We are continuing to monitor as our third party works towards implementing a fix. We apologize for the inconvenience. Please expect an update within two hours.
Posted Nov 25, 2020 - 17:15 PST
Update
We continue to work on the third party incident. To clarify the impact to the Event Webhook: events were delayed between 6:11am MT - 8:11am MT, we took mitigation steps and no webhook posts since 8:11am MT have been impacted. Email API was not impacted at any time.

New Marketing Campaigns Single Sends and Automations are disabled and adding or updating Contacts is delayed.

Legacy Marketing Campaigns is not affected. We apologize for the inconvenience. Please expect an update within 60 minutes.
Posted Nov 25, 2020 - 16:06 PST
Update
We will continue to monitor as our third party works towards implementing a fix. We apologize for the inconvenience. Please expect another update within two hours.
Posted Nov 25, 2020 - 15:05 PST
Update
We are continuing to monitor as our third party works towards implementing a fix. We apologize for the inconvenience. Please expect an update within 60 minutes.
Posted Nov 25, 2020 - 14:12 PST
Update
The third party incident is still ongoing. Impact has not changed - there are still delayed Webhook POSTs and New Marketing Campaigns issues. Single Sends and Automations are disabled and adding or updating Contacts is delayed. Legacy Marketing Campaigns is not affected. We apologize for the inconvenience. Please expect an update within 60 minutes.
Posted Nov 25, 2020 - 13:05 PST
Update
We are still working on the third party incident. Current impact has not changed - there are still delayed Webhook POSTs and New Marketing Campaigns issues. Single Sends and Automations are disabled and adding or updating Contacts is delayed. Legacy Marketing Campaigns is not affected. We apologize for the inconvenience. Please expect an update within 60 minutes.
Posted Nov 25, 2020 - 12:05 PST
Update
We continue to work on the third party incident. Current impact is unchanged - there are still delayed Webhook POSTs and New Marketing Campaigns issues. Single Sends and Automations are disabled and adding or updating Contacts is delayed. Legacy Marketing Campaigns is not affected. We apologize for the inconvenience. Please expect an update within 60 minutes.
Posted Nov 25, 2020 - 11:06 PST
Update
We continue to work on the third party incident. Current impact is still delayed Webhook POSTs and New Marketing Campaigns issues. Currently we have temporarily disabled Single Sends and Automations during this issue. It is also important to note that adding or updating contacts is delayed. Legacy Marketing Campaigns is not affected. We apologize for the inconvenience. Please expect an update within 60 minutes.
Posted Nov 25, 2020 - 10:14 PST
Update
We are still working on the third party incident. Current impact is delayed Webhook POSTs and Marketing Campaigns issues including delays in sends. We apologize for the inconvenience. Please expect an update within 60 minutes.
Posted Nov 25, 2020 - 09:05 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 25, 2020 - 08:07 PST
Update
Further investigation shows that there is also a delay in Marketing Campaigns Single Sends and Automatons due to the third party incident. We are investigating the issue and will provide updates every 60 minutes or sooner if information becomes available. We apologize for any inconvenience this may cause.
Posted Nov 25, 2020 - 08:05 PST
Identified
Due to a third party incident occurring this morning starting around 6:11AM MT, customers may experience delays in stats and event webhoook POSTs to their endpoints. We apologize for the inconvenience. Please expect an update within 60 minutes.
Posted Nov 25, 2020 - 07:15 PST
This incident affected: Marketing Campaigns (Marketing Campaigns), Webhooks (Event Webhook), and Other Services (API).