Increase bounce for subset of mail
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue has been resolved. All services are now operating normally at this time. Please note this incident has impacted emails processed during the incident time period, as well as any links included in the emails. Any emails being affected will need to be manually resent with new branded links.
Posted Jul 22, 2024 - 21:30 PDT
Update
Our engineering team has implemented a fix and is continuing to monitor the issue.
Posted Jul 22, 2024 - 21:16 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 22, 2024 - 20:19 PDT
Investigating
Starting around 18:53 PST on July 22 our engineers began investigating an issue with increased bounce for subset of emails. Customer may experience increased bounce rates the Email Production environment and functionality, including the Mail Send API and Link Tracking, are currently degraded but usable, the team is working to resolve the issue and restore full service reliability. We will provide another update in 1 hours or as soon as more information becomes available.
Posted Jul 22, 2024 - 20:00 PDT
This incident affected: Statistics.