Service Disruption: UI Latency
Incident Report for SendGrid
Resolved
We have monitored the fix and confirmed the issue has been resolved since around 4:45PM MT. We greatly appreciate your patience and apologize for any inconvenience this may have caused. Please contact our Support team with any questions at https://support.sendgrid.com/.
Posted Jun 23, 2020 - 16:31 PDT
Monitoring
Starting around 3PM MT, users may have experienced latency in the UI and had trouble loading pages, particularly for Sender Authentication and Subuser Management. Our engineers identified the issue and implemented a fix. We are currently monitoring the situation and will provide updates. We apologize for any inconvenience this may have caused. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jun 23, 2020 - 16:05 PDT