Teammate Management and Sign-In Resulting in Errors
Incident Report for SendGrid
Resolved
Our engineers have monitored the stability of the deployment to the SendGrid platform and have confirmed that no new teammate errors are present. All services are now operating normally at this time.

Teammates who have not linked to Twilio through the Unified Login feature would not be impacted. If you have linked a teammate, do not make changes to the teammate's profile or permissions as they will be unable to properly login to SendGrid. You can resolve this for impacted teammates by deleting and recreating the impacted teammate using the same email address.

Please reach out to our Support Team for any further questions or issues not resolved by deleting and recreating.
Posted Aug 01, 2024 - 16:06 PDT
Monitoring
At 3:04 PM PDT, our engineering team deployed a fix to mitigate more unexpected errors related to signing in with teammates, adjusting teammate settings and navigating the web console while being logged in as a teammate. Only a subset of users and their teammates were impacted with the aforementioned errors. This incident did not impact mail send. The deployed fix and its results will be monitored for the next 30 minutes for stability.
Posted Aug 01, 2024 - 15:30 PDT
Update
Our engineering team is continuing to work towards a fix. At this time, users may continue to experience errors when signing in with teammate credentials, making edits to the settings for some teammates or navigating the SendGrid console with some teammates. These problems will only impact a subset of users who are utilizing teammates. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Aug 01, 2024 - 14:45 PDT
Update
Having identified the issue, our engineering team are continuing to work towards a fix. As of now, users may continue to experience errors when signing in with teammate credentials or making edits to settings for existing teammates. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 01, 2024 - 13:43 PDT
Identified
Our engineers have identified the issue and are working toward a fix. At this time users may continue to experience errors when signing in with teammate credentials or making edits to settings for existing teammates. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 01, 2024 - 12:44 PDT
Investigating
Starting around 11:40 AM PDT on August 1st, our engineers began investigating an issue with teammate management and teammate sign in. Users may experience errors when signing in with teammate credentials or making edits to settings for existing teammates. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 01, 2024 - 11:55 PDT
This incident affected: Website.