Error Thrown when Attempting to Access Your Products Page
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed that issues accessing the Your Products page are now resolved.
Posted May 04, 2022 - 13:46 PDT
Monitoring
Our engineers have identified the issue causing the Your Products page to throw an error and have released a fix. We will continue to monitor the fix to ensure this issue is resolved. We will provide another update within 30 minutes.
Posted May 04, 2022 - 13:16 PDT
Investigating
Beginning at 12:55 PM PT on May 4, 2022, our engineers began investigating an issue accessing the Your Products page from within SendGrid accounts. Customers will see an error when navigating to the Your Products page. We will provide an update within an hour or as soon as more information becomes available.
Posted May 04, 2022 - 13:01 PDT
This incident affected: Website.