Latency on v3 API Mail Sends
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with latency has been resolved for v3 Mail Sends and Marketing Campaigns. All services are now operating normally at this time.
Posted Jul 13, 2021 - 13:09 PDT
Update
Engineering has implemented a fix and has mitigated the issue. We are continuing to monitor for any further issues. We will provide updates in the next hour or sooner as they become available.
Posted Jul 13, 2021 - 12:41 PDT
Update
Engineering has implemented a fix and has mitigated the issue. We are continuing to monitor for any further issues. We will provide updates in the next hour or sooner as they become available.
Posted Jul 13, 2021 - 11:40 PDT
Update
Engineering is continuing to monitor the issue and believe customer's may continue to see issues with higher than normal latency with V3 Mail Sends and Marketing Campaigns. We will provide updates in the next hour or sooner as they become available.
Posted Jul 13, 2021 - 10:26 PDT
Update
We are continuing to monitor for any further issues. We will provide updates in the next hour or sooner as they become available.
Posted Jul 13, 2021 - 09:33 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 13, 2021 - 08:39 PDT
Monitoring
Starting around 8:15am PDT on Tuesday, July 13th our engineers discovered latency with v3 Mail Sends and Marketing Campaigns. The issue has been identified and are currently monitoring. We will provide updates in the next hour or sooner as they become available.
Posted Jul 13, 2021 - 08:34 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3).