Error creating API Keys & Teammates in SendGrid console

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed that users can now create API Keys & teammates again.
Posted Dec 04, 2025 - 16:34 PST

Monitoring

Starting around 3:40 pm PST on 12/04/2025, our engineers began investigating an issue creating API Keys with custom access & teammates in the UI. API calls to create API Keys & teammates were not impacted. This did not impact mail send.

Our engineers have implemented a fix and are monitoring system performance. Users can now create API Keys & teammates again. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 04, 2025 - 16:03 PST
This incident affected: Website.