Legacy Marketing Campaigns not loading for some customers

Incident Report for SendGrid

Update

Our engineers are continuing to monitor the fix for the issue. We will provide another update in another hour, or as soon as more information becomes available.
Posted Apr 08, 2026 - 09:19 PDT

Monitoring

Starting around 08:00 AM PDT on April 8th, 2026, our engineers began investigating an issue with a subset of customers not being able to access Legacy Marketing Campaigns. They have deployed a fix & are continuing to monitor for functionality. This did not impact mail send.

We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 08, 2026 - 08:17 PDT
This incident affects: Legacy Marketing Campaigns.