Our engineers have monitored the fix and confirmed the issue with Global Stats Delay has been resolved. All services are now operating normally at this time.
Posted Apr 26, 2023 - 15:02 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 26, 2023 - 14:32 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 26, 2023 - 13:43 PDT
Investigating
Starting around 12:59 PM PST on April 26th 2023, our engineers began investigating an issue with delays in Global Statistics. Users may experience see delays in their Global Statistics page by 1 hour. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.