Technical Incident - Stats Delay
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue is resolved. All stats that were delayed for mail send related events have fully dequeued. We apologize for any inconvenience this may have caused and thank you for your patience. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted May 29, 2020 - 11:38 PDT
Monitoring
Our engineers have implemented a fix and are now monitoring its performance. We will provide additional updates as they become available. Thank you for your patience and please contact our Support team at https://support.sendgrid.com if you have any questions.
Posted May 29, 2020 - 11:22 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide additional updates as they become available. Thank you for your patience and please contact our Support team at https://support.sendgrid.com if you have any questions.
Posted May 29, 2020 - 10:13 PDT
Investigating
Starting around 9am MT, a subset of customers may notice a delay in stats for mail send related events such as Processed, Deferred, Block/Bounce, and Delivered. Mail send was not impacted. Our engineers are investigating the issue. We apologize for any inconvenience this may cause. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted May 29, 2020 - 09:41 PDT
This incident affected: Webhooks (Event Webhook) and Other Services (Email Activity).