EU Regional Subuser accounts unable to create API keys

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with EU Regional Subuser accounts being unable to create API keys has been resolved.
Posted Aug 26, 2025 - 13:45 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance. No new issues have been reported. We will provide another update in an hour or as soon as more information becomes available.
Posted Aug 26, 2025 - 13:02 PDT

Investigating

Starting around 12:50 PM PST, August 26th, our engineers began investigating an issue where EU Regional Subuser accounts weren't able to create API keys. Only EU Regional Subuser Accounts are affected. We are currently investigating this issue.

Mail Send is not affected.

We will provide an update as soon as more information becomes available.
Posted Aug 26, 2025 - 12:57 PDT
This incident affected: API.