Delays in Email Activity events

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with Email Activity has been resolved. All services are now operating normally at this time.
Posted Aug 12, 2025 - 12:57 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance. We will provide another update in one hour or as soon as more information becomes available.
Posted Aug 12, 2025 - 12:12 PDT

Identified

Our engineers have identified the issue and are working toward a fix. We will provide another update in one hour or as soon as more information becomes available.
Posted Aug 12, 2025 - 11:21 PDT

Investigating

Starting around 8 AM PST on August 12,2025, our engineers began investigating an issue with Email Activity events. Users may experience delays of up to two hours in some events, particularly in relation to the received events, such as API Keys or Sending IP address. Engagement information is not delayed. This does not impact mail send. The Event Webhook is the recommend alternative if up-to-date data is required. We will provide another update in one hour or as soon as more information becomes available.
Posted Aug 12, 2025 - 11:15 PDT
This incident affected: Email Activity.