Subuser Management IP Assignment User Interface Errors
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed that the aforementioned subuser management problems have been resolved. This incident did not impact mail send. All services are now operating normally at this time.
Posted Aug 08, 2024 - 12:15 PDT
Monitoring
At 11:31 AM PDT, our engineers deployed a change as a means to resolve the issue. The deployed change will be monitored over the next 30 minutes at which point another update will be provided.
Posted Aug 08, 2024 - 11:44 PDT
Update
Around 10:40 AM PDT, our engineers identified the root cause of the errors and are working towards deploying a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 08, 2024 - 10:56 PDT
Identified
Starting at 10:05 AM PDT, our engineers began investigating an issue in which assigning of IP addresses for outbound mail send to sub users within "Settings > Subuser Management" within the user interface results in errors. Errors may include a red banner message stating "not found in the request body". Additionally, intermittent errors may include inaccurate assignment of IP addresses when clicking "change sending" and selecting IP addresses for a designated sub user to utilize. This does not directly impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 08, 2024 - 10:33 PDT
This incident affected: Website.