Technical Incident - New Marketing Campaigns Contact Delays
Incident Report for SendGrid
Resolved
After monitoring the fix, we have confirmed that this issue is resolved. We apologize for any inconvenience this caused and appreciate your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted May 12, 2020 - 14:34 PDT
Monitoring
Our team has identified and mitigated the issue. There are no longer contact delays occurring in New Marketing Campaigns and all requests have been processed. We are monitoring system performance at this time. We'll provide an update when this is complete. Thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted May 12, 2020 - 13:46 PDT
Investigating
We are investigating contact delays taking approximately 20 minutes to process for import, update and delete requests. As a result of these delays, customers may also experience issues with Single Sends when sending to outdated lists/segments. Legacy Marketing Campaigns contact operations are not affected. We will provide additional updates as they become available and greatly appreciate your patience. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted May 12, 2020 - 10:58 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns).