Marketing Campaigns delays, User Interface errors
Incident Report for SendGrid
Resolved
Our engineers have monitored and confirmed that this incident has been resolved. All our systems are operational. The user interface no longer presents delays or error messages, and the marketing campaigns are fully available. All the sends that were still available in our logs were retried. Thank you for your continued patience.
Posted Dec 07, 2021 - 20:52 PST
Update
We are continuing to monitor for any further issues. Engineering has confirmed full access to the user interface, and marketing campaigns are functional. The support contacts channels are now available as well. We will provide an additional update in 2 hours or as soon as more information is available.
Posted Dec 07, 2021 - 19:12 PST
Monitoring
A fix has been implemented and we are monitoring the results. The users are now able to access marketing campaigns and contact support from the user interface. The user interface could still experience some minor delays, and the mail send is consistently recovering. Mail sends that failed due to the outage will be retried in the next hours. The team will continue to monitor the performance of our systems. We will provide another update in two hours, or as soon as more information becomes available.
Posted Dec 07, 2021 - 17:36 PST
Update
Our cloud provider has recently applied a fix that may improve the experience for some of our services. Our investigation shows that the incident is intermittent, and it's currently affecting SendGrid user interface, marketing campaigns. The ability to contact support from the user interface and create chats is improving. For customers that are still unable to contact support through the user interface, please open a ticket by sending an email to help@sendgrid.com if you need any assistance. We will provide an update in 2 hours or as soon as more information is available.
Posted Dec 07, 2021 - 15:44 PST
Update
We are continuing to work on a fix for this issue. Our investigation shows that the incident is intermittent, and it's currently affecting SendGrid user interface, marketing campaigns, and for some users it affects the ability to contact support from the user interface and create chats. For customers being unable to contact support, please open a ticket by sending an email to help@sendgrid.com if you need any assistance. We will provide an update in 1 hour or as soon as more information is available.
Posted Dec 07, 2021 - 13:29 PST
Update
We are continuing to work on a fix for this issue. Our investigation shows that the incident is currently affecting SendGrid user interface, marketing campaigns, and for some users it affects the ability to contact support from the user interface and create chats. For customers being unable to contact support, please open a ticket by sending an email to help@sendgrid.com if you need any assistance. We will provide an update in 1 hour or as soon as more information is available.
Posted Dec 07, 2021 - 12:31 PST
Identified
Our cloud provider has identified the issue and is working towards a fix. Our investigation shows that the incident is currently affecting SendGrid user interface, marketing campaigns, and for some users it affects the ability to contact support from the user interface and create chats. We will provide an update in 1 hour or as soon as more information is available.
Posted Dec 07, 2021 - 10:58 PST
Update
While we continued investigating the issue, we found that besides single sends not being sent out, some functionalities of the SendGrid User Interface may present delays or a generic error. Our cloud provider continues working on identifying the root cause. We will provide an update in 1 hour or as soon as more information is available.
Posted Dec 07, 2021 - 10:09 PST
Investigating
At 8:00 am PST on Dec 7th, engineers noticed that single sends were not sending out. After further investigation, it was detected that the root cause is that our cloud service provider is currently having an internal incident, and they're working on identifying the issue. We will provide an update in 30 min or as soon as more information is available.
Posted Dec 07, 2021 - 09:35 PST
This incident affected: Marketing Campaigns (Marketing Campaigns) and Website.