Unified Account Signup & Linking Failures

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issues with creating a new SendGrid account, linking an existing SendGrid account to Twilio, and changing or cancelling paid plans has been resolved. All services are now operating normally at this time.
Posted 1 month ago. May 20, 2025 - 14:07 PDT

Monitoring

Starting around 12:20 pm PDT on 5/20/2025, our engineers began investigating an issue with some SendGrid account management features. Users may have experienced issues creating a new SendGrid account, linking an existing SendGrid account to Twilio, and changing or cancelling paid plans. This did not impact mail send. 

Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted 1 month ago. May 20, 2025 - 13:34 PDT
This incident affected: Website.